FTP Not working After SDK 33

3 days ago it was running smoothly on Kodular, then after updating SDK 33, uploading FTP files had problems, so I tried it on Niotron but it was the same. You can check it in your project

What kind of files are you trying to upload? And from which directory?
You might need one of the new permissions to do that now…



Thank you in advance for replying. What I uploaded was an image file taken from the camera and from the camera’s default directory. you can see I created a block procedure like that


Show us a Do it result of your procesimage procedure
Are you able to display the image in an image component?
Did you test using the apk file?
Whar is the Android version of your test device?


yes, i can display image in component

I have also tested via APK. as well as my Android version 13

This looks good…

Tell us more about the exact problem
What do you get in the UploadError event?

Upload error

This event returns the reason if a upload was not successful.


there are no errors displayed in the code, when I click the button it will run the FTP.Connect and FTP .Upload File events it doesn’t show any processes
First I added a notifier progres dialog. and it will stop when the upload is complete, but now it only processes, not the Dissmiss

Do you use the Upload Error event? We can’t see it in your screenshot

Does the file appear on the server?
What means


As test deactivate the web3 blocks to make sure, ftp worked before continuing…

Are you talking about web.PostText and the Web GotRext event?

You first should identify where exactly there is a problem in your blocks…


Maybe it’s a problem on Android 13, because I tried it on Android 12 and it worked fine. Thank you in advance

You forgot to answer the questions

I have a problem with FTP when I want to upload an image using a public IP, the Windows server can’t upload it, but if I upload it to hosting it works fine.
The situation is that my Windows Server Public IP can be called with an FTP user in WinSCP,

If anyone has succeeded, please help

We have same problem, when FTP Connect Success then proccess begin but will never end in android 13

try my suggestion here

alternatively try a ftp extension…
for example App Inventor Extensions: FTP | Pura Vida Apps


where i can find demo APK for FTP upload with that extensions

If you read the documentation, almost at the end of the webpage you can find chapter

Test the functionality of the FTP extension

The test app is available in Google Play. You can test the example following these steps

  1. Follow the opt-in URL to get access to the app and to be able to download it to your device.


i want to make sure that extension is can i use to upload file in android 13 before i pay

yes, just test the upload using the test project

IF i pay this extension, where i can confirm my payment and my email

Just send me an email or a PM
See also the large green box on the bottom of this page App Inventor Extensions: FTP | Pura Vida Apps


This post was flagged by the community and is temporarily hidden.