Full Text in Label does not show

(Stem Otc) #1

Hello,
the full text in my Label does not show.
When the text exceeds the width of the screen, I would like it to continue onto a new line.
How can I make it so that the label adjusts its size according to exactly how much text is in it.

Please note the text that is displayed in the variable varies (it depends on the user).

1 Like
(Ken) #2

With default settings:
20190416_133339
As long as it’s not inside a HorizontalScrollArrangement it should automatically do what you want.

What do you have the Width set to?
And is it inside a HorizontalScrollArrangement?

(Stem Otc) #3

The width is set to automatic but it’s still not showing the full text.

(Ken) #4

It should fill the width of the screen then kick to a new line then…

(Stem Otc) #5

It’s inside one cell of a table arrangement. Could that be why?

1 Like
(Ken) #6

Yes, absolutely!

(Stem Otc) #7

So how do I fix it? Because I need it to be in that arrangement.

Should I try using a vertical scroll arrangement or something?

1 Like
(Cian) #8

Play with a few things, just remember that a child component will inherit the component of its parent. You are going to have to try a few things to figure out what works for you and your UI objectives.

1 Like
(Ken) #9

I just tried that and it works if you set the size of the VerticalScrollArrangement:

(Stem Otc) #10

It didn’t work :frowning_face:

For a split second when the app loads, the scroll bar shows up. But then it goes away. Could it just be a glitch?

(Cian) #11

Show your blocks, and paste an image of your design screen components

1 Like
(Stem Otc) #12

(Cian) #13

Your label component is “pinned” in. You need to play with the other components automatic settings, and enable responsive if it is not.

image

(Stem Otc) #14

No that’s not the right label
it’s these ones (that are on the right of the labels that say Name:, Contact Number etc.):06%20PM

There’s no text in them right now so there’s nothing visible there

(Cian) #15

Still pinned in.

You have to work with all the arrangments. It can be cumbersome, but there is no way around it.

image

(Stem Otc) #16

I fixed it by doing this

4 Likes
(Chiggos) #17

please keep arrangement height in automatic in properties.
hope attachment could help you.

1 Like