I can't understand where i am wrong when splitting list at

Hi everyone there!

I’m still a begginner. I’ve read several topics but i can’t find a right solution for me. Sorry if I didn’t it well.

In my block, after getting a list with five items separated by “:” it doesn’t rightly make splitting by dividing point at “:”

I tried trim block but it didn’t work too

Thanks in advance!

(I think the option for reducing the images by % isn’t working)

Your " txt4opRec" is no list at all.
Here is a good tutorial on how to work with list.
I am sure that after studying this you will be able to solve your issue.
http://www.appinventor.org/bookChapters/chapter19.pdf

Hi Django
Thanks for your fast answer and the document.
I set my “txt4opRec” by making a list with five items, and it didn’t work too.
On another hand, i can’t find there any paragraph talking about how to split a list by dividing point .
So, I don’t still know what is my problem
Thanks in advance.

Do it on split text at : block

1 Like

Simply remove trim block

Thanks for your answer pkalyan
Sorry, but i can’t understand what you mean.
As i showed, i used split text at : block, and this is my problem so that i’m asking for help here :wink:

Many thanks for your answer Dora, what was very interesting for my learning!
I tried it but there still is the same matter: split block isn’t work for me :expressionless:

A Runtime error message comes up saying
Attempt to invoke virtual method ‘java.lang.Class java.lang.Object.getClass()’ on a null object reference

Here is when trying to do it for result

And when trying to get result for ‘list’

Any&every help will be warmly welcomed

Connect to companion, Right click on split text block and click Do it and then show ur result

You have to run the procedure for example when button click, when screen initialize etc or use Do it on call procedure block to see the results

image

Also note that Do it works with global variables otherwise in order to test it you have to provide values

Try this example

screen_test.aia (36.2 KB)

Thanks lot Pavan!
I’ve just tried it and split text at : block works well
Now the point is why next get list block doesn’t work for me

Thanks in advance!

Thanks lot Dora!

My text list comes from another part of my code and it provides rightly the text to split at :
but (you can see my last answer here to Pavlan) next get list block isn’t working for me

(if you need to see those others parts of my code, i’d friendly show them here)

You can see my images along this topic, the results from Do it are ok
but when I use Do it on call procedure block then strangely it doesn’t come up any result message

I made sure i’m working with a global variable (you can see my before image)

Then, I’ve tried your example screen_test.aia
When i run it in emulator all is ok
When i use Do it, then no result message comes up and just appears an Unbound Variable notification
Also, if i use Do it on the call procedure in When Button1 .click then no message appears

Thanks again for any help
Regards from Andalucía (Spain)

Then what’s the problem

In my project No label text is getting the select item list as you can see in my image

Just Do it every block and debug the code

That is what i am doing from days and days ago… and don’t find the solution, so that is why i am looking for a solution there

Post your aia here

When you tried this, whats the result? Did lables got text?

Thanks, it’s very long and full of trial and error… i don’t know if it goes to help
but there we go… only for my complicated screen

Industrialismo_Trivial.ais (34.5 KB)