java.lang.NoClassDefFoundError: Failed resolution of: Landroid/support/v4/view/ViewCompat

Hello, I am facing such a problem, I do not understand why it is

java.lang.NoClassDefFoundError: Failed resolution of: Landroid/support/v4/view/ViewCompat;

Do you use Phase extension ?

If yes see

yes I’m using Phase

See above post and you will find your solution

I signed up for the fellow’s beta test

thank you for your help

1 Like

Problem solved ?

there is no warning message. But the design of sleep is broken, it does not work correctly. No, not resolved

Use this

Download [Version: 2.2.0] [Release date: 03/04/2020]

io.shreyash.phase.aix (109.3 KB)

Or if you use beta testing of the companion download phase extension from


I upgraded the plugin to 2.2.0 and 2.2.1 versions problem persists. There is still a warning message

Maybe @Shreyash can help you more , for me it works great with no problem. Depending the platform, I use either version 2.2.0 for Kodular projects or version 2.2.1 for MIT App Inventor projects (supports latest version that requires AndroidX)

1 Like

I am using codulars. 2.2.0 version. The application is running. When I click on the CardView it gives a warning message.
The design works normally. Warning message after clicking CardViev-e operation does not work

@Azad_Habibullayev, can you export your app and see if you get the same error there?

exported and tried. works without any problems

1 Like

I just noticed that you have to delete extension and then imported again. Even thought I get the message that extension is updated it doesn’t work

Then you might want to try this:

I can’t uninstall and reinstall. I used phases in different places in my project. Is there any other way? I uninstalled my companion and downloaded it again

You don’t need to reinstall the extension. Delete the AppInventor/assets directory on your phone like explained here. It should work after that.


can you please provide app link of working companion 2021-07-16T18:30:00Z