Kodular hangs at "20 Establishing Secure Connection"

I guess you didn’t try FireFox because that works.


@Manbir try with opera browser

working fine


works fine on opera browser

Firefox browser works perfectly for me.
But Firefox UI is little bit ugly. Because I am person that think UI is most important point in software, can you suggest any working browser with beautiful interface?

  • Mozilla Firefox. The best browser for power users and privacy protection. …
    According to google… Best Browser Is Firefox @Superjay

Hi, everybody.
The same problem. No connection in Chrome, so as in Edge.
But in FireFox it works.
I also don`t like FireFox UI, but this is a solution for now.
I think it has appeared after Win10Home was updated to v.20H2.

Same here hangs at 20%

Whoa! Thanks a lot!
It worked in Opera.

The fix will be delivered with the next update.


Waiting eagerly for the update…

Finally… I’m having so much trouble using Firefox! :heart_eyes:
And I am really missing Kodular with Chrome.

It is a pretty bad choice as Kodular is building apps on the cloud which requires lot of power from PC and using Chrome which consumes most of the Ram usage of pc it doesn’t give much power to Kodular Builder… I prefer Firefox always I only do small projects on Chrome…

Also, Microsoft’s Edge which works on Chromium just like Chrome is a lot better than Chrome, it eats very less RAM, even lesser than Firefox and is also the fastest among the 3, once the update is out, I might use Edge for using Kodular.

Yes Edge better no need Of installation No lags like Chrome Not Buggy UI Like Firefox Brave Also good But installation Needed I Prefer Edge

Edge also chrome based browser only working .

i’m using the portable Slinjet Ver. (basead Chromium 87.0.4280.66) browser, win10, no installation needed, it works smoothly, it is possible to download old versions, here kodular did not work on chrome, avast browser and edge, it worked on firefox with a scroll problem in the editor.

I had raised this issue on 29 jan. Was using chromebook beta dev version 89.0.4389.16.

Had to come out of the beta program at that point. was fine till the new version caught up.
Now the chromebook is updated with the latest version of chrome Os. Screenshot 2021-03-24 20.09.55 Now Stuck with 20% loading.

Did any one solve this on chromebook with installing firefox or any other browser. It has not worked for me.

Other option I have is installing firefox on linux (beta) which I am not sure if it will work.

Any thoughts on this.

Thanks in advance

this problem needs to be resolved fast as we’re not able to live test our apps. kodular staffs kindly take it priority.


Please see… As @pavi2410 states the staff is already implementing the solution in the next update… Please have patience till then and use Firefox


i know what he said, I’m asking to take it as priority, read my reply again.