setWebViewString property does not work

Hello everyone,
I am testing in WebViewer component, but the setWebViewString property does not work. Is this a bug?

Hola a todos,
Estoy probando en componente WebViewer, pero la propiedad setWebViewString no trabaja. Esto es un bug?



Thank you.

Can you test it with another example too?
I will look into it tomorrow.

I’m going to try.

Have you read this and tried the example?

1 Like

Yes, that example used to test but it does not work.:sweat:
Thank you

I have testet current the example from @Taifun

And it works perfect how it should.

So there is nothing wrong with our webview string.
@marioferj please do it like you see it in taifuns example.

1 Like

Are you sure it is window.AppInventor not window.Makeroid?

We have nothing changed on the webview string.
So window.AppInventor is correct

1 Like

Yes, I use the example of @Taifun.

but the setWebViewString property has to return “hello from Javascript” …
return "hello from my app"

With Makeroid.

With AppInventor

@Taifun Can you help here in this topic?

sorry, I cant test this at the moment…
I only do have an Android 4.0.4 device currently and it seems to be, the companion app does not work with devices < Android 5? Just a guess… The Makeroid companion app force closes while starting…

Unable to instantiate activity ComponentInfo… ClassNotFoundError


Oh… that’s not good.
Have you a full logcat info for us?

thank you.

here you are (3.1 KB)
( I had to zip the txt file, because txt files are not allowed here in the forum?)

I was using an old Samsung Galaxy Tab running on Android 4.0.4
what id the minimum Android version for Makeroid?


Android API Level 14

Thank you. @Diego please look why txt files are not allowed.

Solved :+1:

Unfortunately I got always the same error in reading and interpreting string form html/javascript files, there’s something conflicting, maybe with companion, as you say the webviewer is the same used in other platforms, in this template by Ben e.g. the web viewer does not show the navigation drawer (from the original aia I only cut the fab button as it is imported as ext.). In an other one by Taifun when you select an item, there’s no actual selection.
I have two devices with Android 5 lollipop
NavigationDrawerActivity.aia (31,8 KB)
listview_thumbnail1.aia (140,6 KB)

Does this happen with compiled app? @Tiziano1960

Yes it happens with aia and apk files