SurfaceView not working after Fenix Update

Not sure about whether it is reported or not but it has bug. Fenix with surface view exten

Is your problem is solved? Because I have same issue​:sleepy:

SurfaceView is working fine under Android 7 as before. I just tested it.

I created an app that only opens SurfaceView. It still does not work in companon or as an apk on Andriod 8.1. Did you create your apk since the introduction of Fenix 1.5? If so, what did you do to get it to work?

I have an extension agoraRTC, not working after the Fenix update, in which i used SurfaceView. It,s working on Mit server.

I have also problems with surfaceView.
It worked well before the fenix update.

I have 2 floatbuttons on SV. If both of them are visible, i see this; It shows till the floatbutton.

When I make the buttons unvisible;

1 Like

@Vishwas why isn’t this present among bugs in bug tracker? This is a serious problem that have to be fixed ASAP

1 Like

Really strange that none of the betatesters picked that up when it was time to test. Or didn’t the betatesters test? Maybe we would have had fewer problems now.


Hi everyone !

Well, same issue that Michael_Lee_Corley described :
works fine before Fenix Update on Android 10.

But now, only shows white screen, no preview (even if the take picture event works). The blocks are very simple…


Try to change orientation, make some property changes but with no result.

Try this one surface.aia (2.3 KB)

1 Like


This aia works perfectly.

It seems that the component SurfaceView have to be fullscreen with no other component on screen, even Title, Statutbar, Button… (Floating button creates a white stripe)

In this case, impossible to do on screen preview. Ok another challenge !

Thank you for this solution, hoping this “issue” should be fixed soon.

This post was flagged by the community and is temporarily hidden.

1 Like

OK so its still work if you send the preview to canvas component… but the framerate so so… it much better if the picture shown on it self…
but that much better for fast fixing, than waiting the kodular fix this bug… if you has urgent project like mine…just imagine that an “engineer’s tape” lol

This is not listed on the “Kodular Fenix Bug Tracker”. Is this bug going to be fixed?

it still works, but you need to “Unvisible” almost anything… and put the surface view on top everything on the screen… and that will made your overlay didnt works anymore… that sad…

OK so I got the better solution, by using Pro camera: The pro custom camera‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ ‌ - #14 by Xoma extension…
that ext. work great as the “old” surface view, but it cannot auto rotate your taken images by it orientation, but you can simply using the container size to determining you taken image size…

and new problem also coming, now you cannot do taken image preview as simple as : image taken → change dummy image ->taken image

because i see now the new update only access it own data’s folder by default… so you cannot do image preview in the simple way, if you put your taken image on the root folder or Pictures folder

1 Like

It looks like working now. Tried on BETA


After running many test I believe the problem is with items placed on to of the SurfaceView. For example, in my app I place a .png image with a transparent background on top, using the surfaceview as a background. Prior to the Fenix update this worked, but now the .png image has a solid background, thus totally blocking out the surfview. This also happens when any object, for instance, a button is placed on top of the surfaceview.

You can easily test this with the small app you created above by simply moving your “cam” button down on top of the SurfaceView window. If you do you will see the surfview is no longer visible. Thanks you your attention and work on solving this issue.


yap… you cannot put png overlay on top surfaceview now… it just works if it full screen and has no overlay on top of it

Good news. It appears Surfaceview is working again. The only difference I see is if you can’t keep it open and go to another task because when you come back the same old problem with items placed on top reappears. This is easily fixed by stopping and restarting surfaceview each time you leave and return. Many thanks to whoever fixed it. If you will post and acknowledge fixing the component I will credit you with the solution.

1 Like