Using Google Sheets without Extensions

Hello everyone!

I’ve been searching for a solution to use Google Sheets as the backend for a simple database app with Kodular and since topics similar to my question/plea for help have already been closed, I’m creating a new one.

What I’ve done so far:

  • Searched for the terms “Kodular Google Sheets tutorial.”
  • Looked into METRIC RAT AI2 - Google Sheet CRUDQ II page.
  • Downloaded and tried to import into Kodular the .aia file given in the web page. However, as the import failed with a Web component version error (the .aia uses version 7, while Kodular uses 6).
  • Tried to recreate the (Kodular) project from scratch, based on the imported project (via App Inventor, which works).

I was able to recreate the UI from the designer, but I’m having difficulty with the code block (encircled portion).

The block is a “direct copy” from the App Inventor block, and unfortunately, the global variable dataList isn’t populated. I’ve manually entered into a browser tab the complete URL that the Web component uses and it does output a JSON string

[["last_name","first_name","address","city","state","country","postcode","phone","mobile","email"],["Adnet","Verla","44522 Anzinger Alley","Round Rock","Texas","United States",78682,"09035 456576","02852 111418","[email protected]"]...

And upon checking, the “response Content” the web component receives isn’t exactly the same string as above but looks something like an xml file for a Word document.

Is there a way to isolate the JSON string from what Google spits out? Or a better way to read the output from Google?

Any help is highly appreciated.

Did you set in project settings - Show Lists as Json ?

Show that complete responseContent…

Grabbed as much of the screen as the screenshot app on my phone would allow…

That is a Google Sign In page (in html).

This indicates that your script is not correctly setup.

No. I did not know that. :smiley:

I’m relatively new to Kodular and I’m still learning the ropes, following and learning from tutorials and guides on projects I’m interested in.

Set the Show Lists as JSON option to on, but it didn’t seem to make any difference…

You have picked quite an advanced and technical guide to follow :wink:

I see.

I’ll double check.


I actually had two Google Sheets open, and the sheet accessed was not the correct one, hence the error.

Thanks for pointing me in the right direction. :smiley:

I love to challenge myself to the full. :smiley: