What am I doing wrong? Notifier

Notification is triggered, but when I click CLOSE the ShowAlert does not appear and the application does not close.

What have I done wrong?

If get. Selection = close
Then close application
Try using this

nope . already tried.

Dialogue is costum message and you using costume dialogue :thinking:

1 Like

Use set the button text to close. Are you sure the notifier selection contain the text “close” bcz I don’t think so???

Same thing. There is no block otherwise.

@Deepanshu_Arya . It is the button text needed.


And you can also take call notifier1 in if then block

Try taking notifier1 inside the if then statement

Are you switching screens correct?

No screens. All in one.

I tried with Notifier1, and it did not work, so I created a second notifier just for this function.

I have an idea of what might be happening. If it is correct, it is a bug, I am investigating now.

BTW this is a >4500 block project, so we know gremlins appear at larger projects.

Does the same happen in a complete new project with the same blocks for notifier?

Try Using this Block. Check if the title is the same and do the function here. Since there is only 1 button you don’t need a choice for it. Hope this Solved your problem.

The Problem was that you were using the event Block for Custom Dialog instead of Custom Message Dialog.


Already tried. Did not work. Trying a simple app now

Can you show the Block?

Well i showed the original blocks exactly as they appear on the builder.

Dont use the Contains text block. Just use the logic block to check if the title is equal to Invalid Device and then just use the close Application Block.

But I am not even getting the status update I am getting there, so I know it is not a logic issue. I am not even gettig to that event handler.

Trying these blocks now in a one only project

Fail. Does not work. Can someone confirm?

Did you see the Block I send? Please look carefully and send your blocks image after using the block i asked you to use. Thanks. You’re still using the wrong block in the image

1 Like

Yup . That was my first try. I reverted back to it.

Still no work, but this block set DOES work in a small app.