Access storage when recording audio

I am building an app that records audio. When I click the record button (which starts the recording), it only asks to use the audio permission but it also should asks to use storage to save the audio file. How do I ask to use the storage permission?

Thanks in advance.

After the audio has been recorded, the file must be saved somewhere. Usually in: storage/emulated/0/myRecords/ (or …/Download/ or …/Music/ or …).
storage/emulated/0/ is the root directory of the SD card that requires WRITE_EXTERNAL_STORAGE permission. Therefore you / the user will be ask to grant this permission.

When I use the directories you suggested, it gives me an 802 error and says that there is no such folder. How can I make a prompt that asks for storage access?

Thanks for the help.

Show your (relevant) blocks.

1 Like

These are the blocks I’m using. I am using the sound recorder and button blocks.

If the folder does not exist, it first must be created. Use the File component for this:

3 Likes

Note: You must ask for WRITE permission manually:

see here: File path for unzip file component

3 Likes

Thanks for the quick reply. Can I ask for two permissions at once? Right now, if I ask to write external storage and use the microphone, it will only ask for the permission listed first.

Thanks for the help

See here:

1 Like

this block once i stated recording file has saved but second recording time first file auto remove, no get file list . folder inside always show one recorded file . how to solve it ?

If you set .SaveRecording eg to:
/storage/emulated/0/Music/myRec.3gp
then of course each recording will be overwriten.

Try something like this:


Then you will get:
myRec1.3gp
myRec2.3gp

(show your blocks)

1 Like

Or like this by using clock

Thank you all for your help, it was useful to understand how it works.

But right now I have a problem where I am trying to listen to the audio I just recorded but I can’t.

I’m using the exoplayer, i set the source to the file path just recorded, I created the directory, before creating the directory it gave an error, now it ‘plays’, but I hear nothing.

Thanks if you will help.

Which error? Show your blocks.

couldn’t access the file cause there was no directory looks like, but now as i said it gives no error but i hear no sound

sound player kodular

Set the ExoPlayer.Source in the Button_Invia block, like this:

grafik

1 Like

Thanks, that helped and solved it.

Wow, on kodular even the forum is bugged, i keep receveing notification from this post of the same reply.

Maybe it’s a sign since I’m not receiving any answer anywhere to ask here if you know a way to upload and categorize 3gp files, cloudinary doesn’t let me directly and easily categorize it, I tried airtable but I can’t let it work and create a new row, I don’t know why.

I tried firebase storage and it looks like there is a bug for everyone, from what I discovered it sets the bucket to makeroid-companion.appxyz… for everyone and we don’t have access to it.

Kodular offers many options, but they don’t really work ^^?

Are you talking about this:

If you want help from this forum, your first task shouldn’t be to throw with criticism around you.
Tip: Use the search function. Many questions are already been answered.

.

2 Likes