Airtable "Got Row" Issue

Hello Koders,

My Problem is Quite Simple -

After Getting a Row From Airtable the Data Gets UnOrdered.

My Airtable Structure is Like This -

When i Call For Any Row
instead of Giving Data in This Format - ABCDE of Column 12345
it is Giving Data in This Specific Format Every Time - BEADC of Column 25143

Till Last Night it was Ok, i was Getting Data in Ordered Form ABCDE.
But Since Today’s Morning i am Facing This issue.

i Tried to Change Airtable Base,
Re Compiled .apk Several Times,
Re imported .aia Several Times,
But it is Not Solving.

Help Me Regarding This.

1 Like

hello there, it has been asked before many time, have you searched before posting?

Yes But Don’t Found.
Can You Provide Some Links.

Thanks For Your Help.

i will tell you the result that got data will always shows like this, because that will shuffle data, i have tried many times but got the same, instead of data you can use get cell and use that in a sequence to get all row.

blocks - 2020-08-05T103636.312

blocks - 2020-08-05T103639.501

blocks - 2020-08-05T103642.574

1 Like

@ImranTariq welcome back to the community


@Zia_Choudhary thanks, i am busy with my job, so i dont find much time for Kodular and community.


yes, for me too it’s doesn’t get in order, first few mins it will be in order, then it will shuffle, even the compiled apk

So i moved to - Firebase

If you sort the data in Airtable, you get it sorted in your app…

But to get the rows sorted it is better to get each column. Then you’ll see that element 1 in the first column will match the first element in the second column, and so on… so you’ll always get the rows sorted the way you’ve set them up…


I have sorted it but still it’s not solved!

Yes it’s the issue kodular should look upon it to get data sorted in sequence

With “GetRow” it doesn’t work. It has to be with “GetColumn”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.