An error when I export the project, stuck at "Compiling source files"

Hi, I’m new to this forum and this is the first post that I write.
When I try to export my project to an apk file, I am given an error (see the image below). How can I solve? Thanks everyone in advance!

There is no image to be seen? Welcome, you are new to the community so please read the following topic before asking any question.

Have you searched the community?

1 Like

oh sorry, I forgot about the image​:sweat_smile::sweat_smile: Anyway, regarding the error, I tried to remove some useless files because I thought the problem was that the apk was higher than 10mb. In the app there are only 2 images, of 2mb each, so I don’t know what to do anymore and I also tried to search the forum for other people with my same problem, but I didn’t find any.

Now you need to click view log button and send us a screen shot of the log :wink:


Clicking on “View log” appears:

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res / layout / …
________Creating listview xml in res / layout-v21 / …
________Creating xml in res / drawable / …
________Creating splash png in res / drawable / …
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.932 seconds
________Compiling source files

AAPT is a very common error and can have many causes. You can search for AAPT.

But a common cause we see here is using a packagename that is not formatted correctly. Did you use a custom packagename?

1 Like

As I told you I’m new to the platform, can you please explain to me what’s the packagename?

See here:

If you don’t know what it is you probably haven’t used it. Search for AAPT on the community.

I entered a packagename (com.jacopo.videodownloader) but nothing has changed

Did you search for the error on the community and tried some of the solutions there?

Can you show what extensions are you using.I’ve experienced this problem before because of an extension.

Is this an aia you got somewhere else or did you made the project yourself?

1 Like

I have not used extensions, I leave you the .aia file of my projectDownloadMedia.aia (936.5 KB)

1 Like

Does it work now @Jacopo_Biondi?

He had project in a project…

Two common mistakes by user that produces this error

DownloadMedia.aia (707.5 KB)


Thank you all!! I solved my problem, I managed to export the apk!

1 Like

yes, pack name is com.myhouseuy.Reinvendandome

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.