App compiling problem

El error de compilación fue
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.719 seconds
________Compiling source files
the problem is not package name,
I put without name and with extension com.myuser.appname
block error is zero
zero extension

Is this of any help??

Or this might be the solution​:point_down::point_down:

Also Welcome to Kodular Community :partying_face::partying_face: Hope above posts solve your problem

1 Like

IS NOT THAT :frowning:

Don’t shout here please…

Sorry, I had the google translator, sorry again

The format is fine, I also tried not to put text and leave blank, the package name is without spaces (com.myhouseuy.reinventandome) I also tried only 12 letters to the name of the application thinking that it could be that

See here:

Check you don’t have a project inside your external_comps folder.Like:

thanks for your comment, I have installed Kodular Eagle Version
I can’t find the folder you indicate on my system, it doesn’t appear on disk c or d.
excuse my clumsiness, these are my first experiences on this platform

As i said, export your aia> unzip it> find the assets folder> open the external component folder> if you find another project inside, soemthing like this:

Delete this project> now import your project again to kodular> try to export the apk.

What is you have in your aia file? it shouldn’t be their in your aia file :thinking:

It is to the aia file, passed to zip to unzip, then delete it and there zip again without that file, perhaps it is best to start the application from scratch and see if it happens again

How is this a solution? :thinking:

1 Like

Hello friend, I decided to put all the blocks in the backpack, delete the project and do it again from scratch, I do not know the reason but it did not make an error, it is seen that at the first opportunity I made a wrong step