Audio cannot be played - Unable to load (Only with AAB)

I thought with the update today it is fixed, but unfortunately no.
In Companion it works, but not when I install it.

The problem:
I can not play audio. I always get “Unable to load …” (Error 701). Even if I select the file directly in the designer, the same error occurs. So I tried this method, see picture, but also without success.

Can someone help me? Do I need to specify a different file path? I just want to play an mp3 file from the assets.

Why do you have a folder called assets? Remove the /assets/ bit and see what happens.

Thanks, but unfortunately that does not work either :confused:
As I said, even if I set it only via Designer, even then it doesn’t work.

What is so special about the mp3? Is it a very large file?

Are you testing with the companion or after you build?

No, it worked all the time. Only since the Fenix update it no longer works and the update today could not help. The file is just about 400 KB in size.

Both. With removing the /assets/ its also not working with Companion. If its like in the picture above, then it works only for companion but not after build

I see that there is a dot after the end of “mp3” in the error message. I do not know if this is normal, but in the source is definitely no dot after mp3

For example:
…/FileName.mp3. (The last dot can be seen in the error message. But it is not part of the file name.)

How about showing us all the relevant blocks.

That’s all. Once set the source and then only the block to start.

Are you sure that the MP3 file exists in the ASD?
If so, try file://<GetASD>/Teiil2.mp3

Which Android version?

Android 11. I’m just trying to play a file from the assets. I’ll try it as suggested and get right back to you.

What has this path to do with the assets?

If you want to play a MP3 file from the assets, set the source like this:
Player.Source_to Teiil.mp3

Are you sure your file is named Teiil2.mp3 with two “ii” ?

1 Like


Since it did not work via the setting in the designer, I just tried other ways and this came out among one other thing with the /assets/ part. What would be the right path?

Works fine, no issues at all (Designer and / or blocks):


Okay, I’ll try it out right away. I had the problem directly after the Fenix update, with today’s update I had completely forgotten the simplest, so just the file name, and not tried it.

I have tried and it does not work. I do not understand it.

Note: I know there is a dot after mp3 in the error message, but it is nowhere to be found. The source is simply “Teiil2.mp3”. As I said, back then, before the Fenix update, everything had worked smoothly.

A stupid question, is the file even uploaded to the server?

Do you mean that the file is uploaded to the assets? If so, then yes. It is there and I can also play it in the Assets Manager.