Audio cannot be played - Unable to load (Only with AAB)

Can you post a demo aia

Can I send you the file privately?

Does this app work for you?
mp3Assets.apk (5.3 MB)


Works as it should on my end with companion, I presume it was on companion you had issues or was it in apk…


Yes, with Companion it works for me too, but not with aab.

Since it works with my test app, it should work with any APK. So what’s the problem? And what does that mean “apk / aab”?

APK works, AAB can only be tested once the app has been published in the Play Store or using Bundletool: bundletool  |  Android Developers.

So what are we talking about here: APK or AAB?

Sorry, my mistake. It’s about AAB. I just checked again with my app, with APK there are no problems, but with AAB there are.

It took us 27 posts to clarify this. :upside_down_face:

Then how did you test the app? Did you upload the AAB to the Play Store and then download the general APK from there?

1 Like

AAB loaded from PlayStore, APK loaded directly after build without PlayStore (APK tested on smartphone and BlueStacks)

Just posted this at MIT

Edit: This one is extracted apk from aab file

1 Like

Go the Play Developer Console and download the general APK to your computer, open it with WinRAR / 7-Zip and see if the assets (MP3 files) are there.

Maybe this issue / bug is still not fixed.

Okay, so:
Player works with APK, not with AAB
ExoPlayer works without restrictions

Files are there

So thanks for the help everyone.

Yes, there was my experience back then too.
But did you check this uploading the new AAB (using ExoPlayer) to the Play Store?

Yes, I have done that. With the ExoPlayer everything works. It is only the player that has problems with AAB.

Then this bug still doesn’t seem to have been fixed.
@pavi2410 @Vishwas

1 Like

See here (from Evan W. Patton - MIT):

1 Like

See also here: @Diego

1 Like
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.