Block connection sound

Hey I love Kodular thanks for all of your great work. I would love to have the option to turn off that clicking sound if I connect blocks with each other. Is that possible?

Maybe @Vishwas can add a settings option at the creator settings page for it?

1 Like

And there is option in browser for mute sounds from specific site

I use Safari and the clicking sound doesn’t let the sound icon appear. Thats why I don’t have a clue how to mute the site.

Try by right clicking on that tab

No there is no option to mute just other settings.

In Chrome it has an option for “Mute site”.

1 Like

In Safari on a Mac, you can mute a tab in multiple different ways. While the current active tab is playing sound, a speaker icon will appear in Safari’s location bar. Click it to toggle sound on and off for the tab.

You can also right-click any tab and select “Mute Tab”, or just left-click the speaker icon that appears at the right side of the tab.

1 Like

Safari doesn’t register the clicking sound als real sound that’s why I can’t mute the tab how you described.

Did you try right-clicking it? On Macs, that might be control-click. A list of options should come up. Select “Mute Tab” as Hassan_Alzaki described.
What’s wrong with disabling all of the audio? Are you listening to an audiobook in the background? You can always mute all sounds.
You could also try muting your whole web browser, so anything outside of your web browser gets through but any web page is muted.

Thanks for trying to help. I listen to music in the background. I can’t mute a tab or the whole browser if there isn’t a constant sound produced like when watching youtube videos.

It doesn’t work for the creator.

Try to upload a sound file in the asset then play it. Then check if the sound icon appears.

The icon appears even if the clicking sound comes but it is for such a short time that I can’t click it before it disappears again.

Yes that is why I presented my work around method. Once you play a sound go to the icon and mute.

The sound file doesn’t load. :grimacing:

If you have used the dev console, you can paste in the following code to disable all sounds.

for(var workspace in Blockly.allWorkspaces) {
    Blockly.allWorkspaces[workspace].SOUNDS_ = {};

Some help on how to use the console:

1 Like

Just try another valid type format.

Thanks that worked perfectly.

1 Like