Companion not working

Make sure you’re using http://builder.makeroid.io not https.

3 Likes

WoW! The problem is solved and it connected pretty quickly. Thanks for your support :slight_smile:

1 Like

sir after drako update… my companion is not working… in chrome, kodular is redirecting to https

what should i do now?? pls help

Conor posted that 7 months ago, so it is not valid anymore. Also companion is working with HTTPS now.

1 Like

no its not… after scanning the qr code nothing happens. without live test its very difficult to make app. i also tried http:// but it redirects to https://

and i dont know what to do now…

3 Likes

yes same problem

please give solution @Peter @Mika

Same problem here. When I scan the QR Code the QR code goes of in the browser and then a dialog comes showing 20% sending some files. It remains at 20% even after an hour.

1 Like

I am trying to report this issue for quiet some time. I take my phone and scan the QR Code. After scanning the QR Code disappears in the web browser(Microsoft Edge). A dialog with a linear progress bar pops saying Establishing a secure connection at 20%. This 20% never goes up even by 1% in the next 1 hour. This is how I am not able to use companion to test the app and always have to export and apk through QR Code which takes a lot of time.

1 Like

You have to give more info then just that. And don’t use Edge. Use Chrome, FireFox or Opera but not Edge.

  1. Try again.
  2. First check if the app is compiling without issues.

/Boban

Tried it many times but still did not work.

Hello Community
I have had this problem before, the companion would not connect or would freeze and the browser would either not load or freeze at 20% and it was after doing these things that I was able to get it working again.

  1. Delete the cache on your browser (make sure to save and download the AIA file of your latest work first) Most people use Chrome.
  2. Delete the cache of the Companion app on your mobile device
  3. Uninstall and reinstall the companion app
  4. Use Opera Browser if Chrome is still not working.

I have found that the companion works better from Opera or Vivaldi browsers than it does from Chrome but that is just my personal experience and with a Mac.
I hope this helps someone.

1 Like

Pain in the b** to do this every time especially if it happens 2-5 times a day, do not you think

/Boban

I only had to do this loads of times while using Chrome
It does not seem to happen with Opera or Vivaldi browsers or at least it has not since I last had to do it.

I now Work like this.
Chrome for Viewing Opera for working as I am on High Sierra I have the Split screen option so I have the Chrome on the left and the Opera on the right, I use the Chrome to go through my blocks and view them or copy them, I use Opera to work on the blocks and use Companion and create apk.
Since starting to work like this I have not had any problems apart from having to delete the cookies every now and again.
Again this is my personal experience working with Mac a lot of people use Windows or Ubuntu

The companion app works well when I scan the QR code. But later if I change anything in the app creater like color, text etc. The kodular companion app crushes.

Yeah Thanks A lot it ReallyWorked