[expected bug]Issue with lists and Mysql data

i am facing an issue while getting data from mysql and storing in lists
previously it was working fine i used kodular last night after one month
my table consists of 6 coloumns and only one row

when i call Select * from Table query
it give response content having all data of alll six columns
but when i used list from row csv table list block and try to get spicifc data in differnt lables
it did not work showing that lists lenth is just 3
u r trying to to get item number 4 of a length of list 3.
m not sure what i am doing wrong or otherwise this is an isseu in kodular



actually i have 6 columns ands 1 row
on fetching data i should have a list of length 2
at index 1 there is my column header names
at index 2 there are my records

my first column is Id (Integer)
second column is Name (VarChar (100))
third Column Address (VarChar (100))
forth column Data (LongText)
fifth column Total (Int)
sixth column pic (Text)

and on fetching data i should get a list of length 2

but in my case i am getting a list of length 3

its happeing due to large text data in data column
because if i try by using a liitle sample data of less chracters then it works fine.

this rediculous behaiour is occuring is lists
bcz data is fetching correctly some how lists are geting divivded and showing that there is a list of length 3 instaed of actual length 2.

just try my axample apk and u will get to know my point

blocks (82)

blocks (84)
blocks (85)

blocks (86)

try it without uploading data
listIssue.apk (5.4 MB)

1 Like

I configured to get my mysql.php and my table, I changed a few things. And, theoretically it’s working with the data in my table.

1 Like

UPDATE yourtable SET yourfield= TRIM(REPLACE(REPLACE(yourfield, CHAR(13),’’), CHAR(10),’’))


Select TRIM(REPLACE(REPLACE(yourfield, CHAR(13),’’), CHAR(10),’’)) from yourtable

1 Like

its showing error
#1054 - Unknown column β€˜β€™β€™β€™ in β€˜field list’

Exchange the quotes. :+1:t2:

Not worked

The affected line is returning because I already removed the chr (10) and chr (13)
The blocks I am executing are different from yours. I removed the header. I did the test with your big text.
On the first attempt, he returned 8.
I used only the first paragraph.
Returned 4.
So I removed the chr (10) and chr (13), the result returned 3.

i tried with your aia but the problem is again same

Did you remove the header?
Your update works ?


yes i removed char 10 and 13

The blocks I had are working. The number of records is returned (without the β€œheader”).