Firebase "GetTagList" Bug

[*] I checked out Bugs in Kodular Eagle before creating a new topic

Describe your issue

Firebase GetTagList block doesn’t work if all the tags are numbers. If there is a single tag that is not a number then It works fine but if not then GetTagList block doesn’t return anything, not even an error message or something.

Steps to reproduce the issue

Create some tags with number only. like this :point_down:
then try to GetTagList, it will return nothing

Expected Behaviour

it should have returned all the tag list

Actual Behaviour

It returns nothing, not even an error message.

Show your Blocks

Here is my blocks.

Firebase Token, URL and Project Bucket are okay.

Android version

Checked in Android 9 and Android 7

###Additional Information
This bug was also there in thunkable once but they fixed it, see in the below post of Thunkable community.

Also, I’ve tested that same project in thunkable as well and their GetTagList block was working perfectly fine even if all tags are numbers.

I hope I gave enough information about this bug and it will be solved in next possible update.

ive created a APK made of both Kodular and thukable so that you guys can understand this issue better. The issue is only in Kodular not in Thunkable.

Here is the blocks:

APK Made of kodular: GetTagListKodular.apk (5.8 MB)
APK Made of thunkable: GetTagList.apk (4.2 MB)

AIA: GetTagList.aia (2.5 KB)


You trie delete component length of list list ?
Label1.Text to > get value

Also, if you delete 1 and 2 from the list, it will work. I think a problem will come to 1 and 2 at the start of a list

Try getting tag list in a list view.

When firebase got tag list
Set list view elements to get value

I don’t understand, if you are saying get value directly as lable1 text then ive tried it and not working.

this is also not working. Results are same whether there is 1,2 tag are or not

same results

ive created a APK made of both Kodular and thukable so that you guys can understand this issue better. The issue is only in Kodular not in Thunkable.

Here is the blocks:

Please @Kodular have a look at this issue.

APK Made of kodular: GetTagListKodular.apk (5.8 MB)
APK Made of thunkable: GetTagList.apk (4.2 MB)

You cannot say it is a bug before it is confirmed as a bug.
Change your category to #discuss first.

1 Like

I am pretty sure that’s a bug becuase of the following reasons.

1.I’ve tried everything, checked every block and method and properties of firebase component.
2.As I mentioned in my post, this “bug” was once there in thunkable (Veryfied by thunkable stuff, Mark)

This was a bug in Thunkable caused by some unexpected behavior in Firebase whereby their client libraries will attempt to interpret data where all the tags are integers as an array/list. We have a fix already submitted to our code base and will be in our next release, which should be some time within the next week or so.

In the meantime, one workaround would be to store one value with a textual tag and then ignore that tag when it comes back from GetTagList.

I hope this helps!


Check this Post from Thunkable Community

Most likely, we have the same bug in kodular.
Also, I have given the complete details about this bug and created two APKs of the same project. If you check that, you will understand what I am saying.

I just don’t understand, why any of kodular stuff not verifying this bug or problem or whatever that is. No one even responding to my post.

You can’t force them.

Let’s wait if others have the same propblem.

1 Like

It’s not a bug.

The error is in the way you save data in firebase.

Firebase has a way of saving text, which is like this:

"\"text \""

And the numbers are saved like this:



And what you want to save is a list of items.

Firebase lists of items are saved like this:



If you want to know how firebase saves the data you have to save the data from the kodular blocks and there you will see how each type of data is stored in firebase

So it’s not a bug.

The problem is that firebase doesn’t recognize the type of data you’re putting in.

1 Like

Thank you so much for your response, I appreciate you are willing to help, but you really want to help then at least try the APKs I have shared. If you have checked them then you would have noticed that my app gets tag list even with my wrong database if there is a tag which is not a number like a tag “z” But if you remove the tag “z” Then there will be be 11 tags left and all will be number then try to get tag list, you will get nothing.

Or at least make a tag with any number and then put list in the tags value, and then try to get tag list. According to your theory it should work, but it will not work. That’s the thing I’m trying to explain to everyone. No one is checking the APKs.

It is that an apk for this does not work. Because nobody can see How you make the blocks and the logic. So no one looks at you apk. Share an aia file, but sharing an apk to demonstrate a bug does not have much sense.

(post withdrawn by author, will be automatically deleted in \infty hours unless flagged)

I think when I read your post I didn’t quite understand the problem you were explaining.

What you’re saying, I’ve already talked about it here on the forum.

I don’t know if the problem is the component or the firebase.

Yeah, that’s what I was saying. Finally someone understood. Sorry if I made my post too complicated to understand.

@Peter Sorry to mentioning here directly, but can you please look at this post and clarify is this a bug or what? I directly created this post in the bugs category because of this post of thinkable community. Please do check this out.

Try clearing project bucket in firebase extension properties

This way I will get all tags of my project which I don’t want.

I also had the same problem. I believe that this is not a bug in the Firebase component but there may be some rules for the tags and values in Firebase which we don’t know about. What I simply did that I added a letter with the number instead of directly storing a number. For example:

A1: " \ " value \ " "
A2: " \ " value \ " "
A3: " \ " value \ " "

and so on…

This way it works absolutely fine. You can also replace the letter to blank so that you’ll have a taglist having only numbers in it.

1 Like

It is a good idea but I want to store data with my own structure (As I showed in the post) and that’s the only way for me. I found that easier.

I completely disagree with this because if there would be some kind of rules as you saying in Firebase than how come everything works fine in thunkable? Do those rules apply only to Kodular? I don’t think so.

I also think you need to give a look at this post of Thunkable Community

That post is actually 3 years ago, outdated information might not be applied on the situation now.

1 Like