[FREE] ScanView -ZxingView Version 2- Extension

I have this problem on older cell phone models.(LG K10)
I reported this to Silver in PM.

And I also asked, if possible, to set the reader to a landscape position.

In this not reading issue, I’m giving the user the option to use the default reader.

It is now( last version) possible to use s extension together with the standard barcode scanner

1 Like

Hello!

I’m new to Kodular and I’m searching and trying out solutions (aka extensions) I might be needing in the future. The first one I’m testing out is the creation & reading of QR codes (and other codes). I downloaded the scanview.zip file posted earlier, and am now testing the included .aia file (via the companion app).

When I tried the “Create QR/Bar” button, I got an error, and the app reported it was because of EPERM (Operation not permitted). I’m aware that this is and Android 11 issue, and I’d like to ask for a solution/workaround for this, as this has been bugging me for days.

Thanks, @Silver and @vknow360 for the extensions.

Thanks for your replies.

Welcome to the community @mjolnir , sorry for the late response, please elaborate more, give us more informations about your issue.

is the issue in more than one device or is in your device only?

Try adjusting this block value:
component_method

With a float value from 0.0 to 1.0 the default is 0.1.

1 Like

This is occurring in more than one device. Five devices I tested, to be precise (2 different Xiaomi models: A6 and Redmi 7, Samsung A30, LG K30, Motorola G4).

I’ll test this setting in the same devices and post here. Thanks for your time.

Hi @Silver. Thanks for responding.

Here is what I did.

  • download the scanview.zip file mentioned above
  • extracted the contents
  • imported the .aia file extracted from the .zip file
  • connected to companion

on the phone running Android 11:

  • entered “test” to create the QR code
  • pressed the green Create Qr/Bar button
  • got the EPERM error.

I need help to make this work. I have not edited the blocks in any way.

Thanks very much!

Try changing path to one of the shared dirs such as /storage/emulated/0/Pictures/qr.png.

4 Likes

Yey! That worked! Thanks very much, @vknow360.

1 Like

The same thing is happen when I set front camera in Samsung Galaxy note 9. Runtime error Failed resolution of Lcom/google/zxing/BarcodeFormat. Can you tell me how to solved it?

@Super_Gbond
Which version are you using?!

Hi , @Silver.
I have the same error message. In one project the extension works with Kodular’s bar code component and in another project, it doesn’t. I’ve already removed the other extensions, one by one to check. But the error is still popping up and closing the app.

More details about the error, what I tried, what extensions I use, are in the private message.

Hugs

@Rogerio_Rios
I haven’t receive any PM from you…

In January 28
I cited the error above.:point_up:

And February 3

@Rogerio_Rios Please send me an aia file…

1 Like