I canot enter my aia after export it

At the beginning, I used to import the aia file from MIT app inventor to Kodular. It was success that I could enter (.aia) , but I exported (.aia) file after saving, then imported it again that could not open the file, it stoped in the loading file interface.
WhatsApp Image 2020-04-08 at 2.59.13 PM

Here is my (.aia) file. plz help me and see if it can be solved:
App (1).aia (2.7 MB)

Please try changing the name of the AIA to something that doesn’t contain spaces or special characters (@,#,",’)

1 Like

try this,

App (1).aia (2.7 MB)

Unfortunatelly, I believe it has nothing to do with the name, aia file is corrupted, screens are missing


@Vishwas this was the same issue which i reported on Slack too, that after download aia screens folder missing but i got no reply or response.

1 Like

Is there any way that I could create another aia file in Kodular and copy the original context from the old one?

not working, there are not any special characters

but I still could open it, just cannot export then import

@Derek_YIP was the AIA exported from App Inventor?

yes, when I first import the aia file from MIT app inventor to Kodular, there is a notice told me that something about version unmatched, some part of elements is missing, but I add it back and use the same file to add more functions and elements.

@ImranTariq were your AIAs exported from App Inventor or Kodular?

1)export from MIT App Inventor
2) import to Kodular (file1)
3) I discover there is entering problem in (file1)
4) make a copy in Kodular(file2)
5) use it(file2) to add extra functions
6) export it from Kodular(file2), import it to Kodular(file3)

That’s I am showing is the third version(file3)

that was made in Kodular, actually personally i am not exporting aia that was a friends project which i imported he was also working on kodular and sent me aia, first i face some issues regarding uploading it, and when i fixed that and wants to send aia back to him, i noticed that after exporting aia screens folder is missing, then i have tried to export that screen, but instead of any screen its only exporting screen1. that issue i have faced before 3 days, and reported to team. no i cant say anything that is it working fine or issue is stiil there, also i have noticed that issue only can be seen in bigger projects like a project having multiple screens about 5 to 9.

1 Like

@Vishwas I had an old aia from MIT App Inventor that used Web component, exported aia from App Inventor, imported to Kodular. Got error, pressed ok, exported it and the aia has no screens

1 Like

If the file is corrupted, how should I do?
Since I have to get the aia file, and make it worked. That is my University coursework, so I put a lot of effort to finish it.
If it’s still not working , I have to follow the original one to add all the element one by one.

Are there any ways that could I make a make me do it faster?

yes I got that message too

try exporting screens and add that to desired project.

How to do that?
I don’t understand

do you have project in kodular? which is working and you want to convert it into other, then select screen which you want to export and go to project button, and export screen. and in other app use import screen option and select exported screen.

could you provide some image to illustrate how to do these steps? I really don’t understand.