List of 0 error but my list have many values

Geting all the values from airtable checked on lable even list contain 8 values in all blocks of airtable even though i get this error trying to call valyu from list of 0 ()

You made two mistakes…

No.1 -
when global switch =6 there you put again the global switch to 1, but it should not. So make it into zero

No.2 -
Also you used the for each number block out of the then statement. It shouldnot… actually it should go the condition like when global switch=6

1 Like

Not understood can u please re built the blocks for me .

See the global variable value and the procedure how perfectly placed…
Like this you have to set


I hve not used this aix …i used dynamic component aix and procedure component and want to make dynamic cards from airtable data.

Whatever you use, the procedure must fit into the last if then logic but in your case you have put it away from the else if blocks… see the difference

1 Like

That prob solves now i have a dynamic card view i want any card view click event and want to downlod or scren shot. That perticukar card in mobil storage l
Pls suggest me block

May i know what have you tried ?

Get ID on card view clicked, from the id convert into index, using this index get the image / any other ontent you want to ownload using download block

can u pls send me blocks i get the value of cardview number on lable now furthe i dnt know…i tries several method from community but …no result

Pls give your demo aia else I need to start to do from scratch :sob:

dvpp (1).aia (1.5 MB)
on screen RASID when i click any card view that perticular card should be save in my phone as png or as pdf this is what i want to make…tried lot but i m just achemistry teacher so not much good in coading.

Me too… Wait for a minute… let me check it

Please mention the screen name… you are having multiiple screens

I did like this and got the file in my app



dvpp(3).aia (1.2 MB)

this aia not working for me android 12 . after choose dilouge no further goes

Android 10+ having different procedure for saving photos in app. Save it in asd then move to public folder

Already plenty of guides and suggestions are given by @bodymindpower @Boban as well as @Taifun

Please search regarding that :mag_right:

Based on the title I hope we suggested and solved your issue and got working in lower Android versions

1 Like