Migrating BLE (ESP32) App from MIT Inventor advice

I have a MIT AI2 app in debug. It mostly works and I am OK with the AI2 environment. But, their servers are shaky. I get weird bugs from time to time. Right now, AI companion is basically inop. Server problems of some sort. AI Companion hangs at 20 percent, legacy mode at 92 percent. The emulator is so slow I don’t know if it has blown up, or my app has blown up.

Basically, I am dead in the water as far as development is concerned. No good words on the forum as to when and if this gets fixed.

I tried Kodular about a year ago. I couldn’t get the BLE extension (the AI2 extension) to work. I was wrapped around my own axle at the time, BLE wise & AI2 wise. Likely was my fault.

I hate changing platforms. I have enough problems with my own work, adding a learning curve is something I try to avoid.

Anyone have experience with a similar transition (medium size app, BLE) they would like to comment upon?

Color me frustrated. Deep enough shade to be willing to consider most anything.

Thanks in advance.

Welcome to the community, I think your problem with companion was solved by using Chrome as browser as suggested in MIT App Inventor’s community.

Thanks for the welcome (back). yes, somewhere along the line I discovered that Edge didn’t work, Chrome did.
I have now imported my AI2 Project. I get a constant “the blocks did not load properly” popup.
Thanks for the quick response.
Initial reactions to kodular are good.

Try uploading your aia to unchive and see your blocks, this way you will be able to see if there are blocks not compatible with kodular and if yes, which blocks causes the problem


Thanks, greatly appreciated.
Tried it. Interesting tool. Going back to creator, it appears that lots of stuff didn’t transfer. For instance, there is a big multilevel dictionary that the whole app is based on. No sign of it in creator. as far as unchive, I get a lot of shifted text–as below. Not sure what that means.

The dictionary is in unchive, but not in creator.

I tried exporting the project with all the blocks expanded. unchive seems to see them all, the text skewing has gone away. But, there are a LOT of blocks just missing when viewed in Creator. unchive summary says there are 1904 blocks. I don’t know if this is considered medium, large, or whatever. It isn’t small to me. Is there some upper limit on block count?

Do you wish to post or pm your aia to check it ?

No problem. Don’t laugh too much–I am not a block language expert.StillV8_k.aia (251.3 KB)

Try this

StillV8_k2_1.aia (249.9 KB)

It appears all to be there. What did you do? I cannot impose on your kindness forever.

Many thanks, Rich

1 Like

Basically, it works. This is a project very much under debug, so it doesn’t entirely work at the best of times. But, I am back on the air.

Color pallet is different than AI2. So what. I have horrible color choices anyway. I will make them differently horrible.
BLE connects.
I am off and running.
You have a new Kodular convert. It appears that the conversion isn’t that big of a deal. Some things are different, but my biggest problems belong to me.

1 Like

I do not anticipate having any ads for Kodular to earn a commission upon. Sent a small donation. Bought a couple T-shirts

1 Like

Glad I could help :slight_smile: