"Network Error Communicating with Companion"

Hi:

I’m unable to connect via USB!

The following message comes up:
Network%20Error

How to solve this problem?

Thank you.

3 Likes

Try enable usb teathering and then try

Did it work??

1 Like

Hi deepanshu_da85, thank you for reply!

I can’t find that option in my phone (i’ve a Xiaomi Redmi 4).

You can simply search in setting or go setting>more> usb teathering

If my reply solved your problem mark my that reply as a solution

I enabled the USB option… but it still don’t work!

Do you have USB Debugging On in Developer options? If not turn that on.

Yes, USB Debugging are On! Still don’t work!

Can you download starter for usb test

https://starter.kodular.io/

After download set path to adb.exe in command prompt after its start working

Screen

Refresh you page and reconnect your phone

Screen%20-%20Set%20Path%20-%20C%C3%B3pia
Correction: I changed the path to “C:\adb” (not “abd”).

01

02

Question:
Do i need to Install Python?

No

Check this post i hope its help you

nikhilbobade27, thank you!

Unfortunately I don’t see in the post something that can help!
I think I did all the steps… can’t find something new to try with :frowning:

@pavi2410 will be help you in this case

1 Like

I found the “trick”:

The “network error” occurs if the companion app (in the phone) starts during the “connection” (USB Connection in the Kodular Creator).

This error can be avoid if we run (open) the companion app in the phone, before click on the “USB Connection” in the Kodular Creator (in the webpage)!

I hope this helps for users with the same problem!

4 Likes

Means your problem will be solved

1 Like

Problem solved!
Thanks for help :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.