Recast • Make your old extensions compatible with Kodular Fenix

Recast v0.2.0


  • Added ability to recast extensions in AIA files. Instructions for the same can be found in the first post:

  • Recast now prints a more understandable message if recasting the given extension/AIA is not required.


To upgrade from any older version to v0.2.0, simply go through these installation steps mentioned in the first post:



thanks i solved my error

Ok but how do we import our new extension please?
Capture d’écran 2021-07-19 193546

yes this also happened with me help @Shreyash


The com.appybuilder.kennicholsandroid.TextBoxTools extension crashed for inputting numbers only. I ran Recast for her and nothing changed.
Can someone help me?

Thanks In Advance.

4 posts were split to a new topic: Error 908: The permission has been denied

When i want to do this i got this error. why???

Please make sure you are using the latest version of Recast (as of now, it’s v0.2.0). To check the version, run recast -V.

And do you get any error message? If yes, post it here.

Read this:

1 Like

Thanks @Shreyash for your response

But mine is the latest one but still error @Shreyash

where i do run this??

You are running it in the right place. Now go ahead and run the installation script.

I was unable to reproduce it with the latest v0.2.0. Does this happen only with a specific one or every extension? In either case, PM me the extensions that are showing this error on import.

@Shreyash thanks for your reply
i have tried one extension and it’s giving error

I also use the latest version of recast

I’ve identified the issue. Working on a fix.


Why it is not saving in correct format as exe in my computer ?

It is saving as .EXE.PSDrop.unk

Not quite sure why that might happen. :thinking:
Try removing the .PSDrop.unk prefix from the executable and see if it works. In case it doesn’t, just re-install Recast.

1 Like

This post was flagged by the community and is temporarily hidden.

1 Like


After Renamed showing this :point_down:

Same error happens with other extension also

Extension Path

Even after reinstalling it was saving in .EXE.PSDrop.unk

Recast v0.2.1 BUGFIX


  • Fixed the issue where some extensions won’t get imported in the Creator.
  • Fixed the naming issue of recasted extensions. It didn’t match with the name printed in the success message.


Like always, to upgrade Recast to v0.2.1, follow the installation steps mentioned in the first post: