Starter instalation not working

Hi there,
I am trying to install the starter to test my app no my phone using usb conection but I couldn’t make it work.

What I’ve done:

  1. Downloaded and requirements.txt on the link
  2. Installed ADB and Checked Installation = seems all good
  3. Installed Python and Checked Installation = not sure
    I typed python -V on ms-dos and it showed me the version (3.7.0)
    I typed pip -V and it showed this message:

‘pip’ não é reconhecido como um comando interno ou externo, um programa operável ou um arquivo em lotes.

Which in portugues mean
‘pip’ is not recognized as an internal or external command, operable program or batch file

Even so I downloaded the files and requirements.txt and put them on C:\makeroidstarterscript
I tried to put them in others places too but nothing made the starter open.

I thank you in advance for helping.

This is a known issue being fixed!

1 Like

PS: This step “3. Run this command on the same directory where the Makeroid” I couldn’t understand very well. It’s the directory where the adb is installed? Where the files are installed?

Pleas regard what I just replied with.

1 Like

Oh thank you.
Do you know if there is a way to avoid the problem?
For example, I am on windows 7 64 bits. May be it wouldn’t happen on windows xp, windows 10 or windows 7 32 bits.

Nope, it’s an issue with the code and the new update.

1 Like

thanks a lot man.
When I typed the last message I didn’t have seen yours yet.

Last question: is it necessary to close the topic after answered?
If so how do I do it?

Nope only if this goes off-topic…

Nope you’re Trust Level 1 and only Admins or Moderators can do this! If you want it closed, you may ask @Peter here.

1 Like

If you are using Windows:

  1. Download this file
  2. In the downloaded folder, execute python being an administrator

If you are using Linux:

  1. Execute sudo apt-get install python-pip python3-pip
1 Like

Successfull installed, thank you Diego!
But now I came back to “Check Installation” step and got this
The last message in my language means:
‘pip’ is not recognized as an internal or external command, operable program or batch file

Close the console and open it again


same thing :frowning:
I restarted the computer and still the same
I found this tip in Google:
Insert “C:\Users\Pablo Almeid\AppData\Local\Programs\Python\Python37\Scripts” in the Path of windows.

So I am here now:

But I am not sure how to insert the text “C:\Users\Pablo Almeid\AppData\Local\Programs\Python\Python37\Scripts”
Is it just to paste that in the end of the line? Or put “;” and then paste this?

Add at the end of the string ; and then C:\Users\Pablo Almeid\AppData\Local\Programs\Python\Python37\Scripts


I put the files and requirements.txt in the same place where python is installed. It’s not a problem, right?

Anyway, i executed pip install -r requirements.txt and successful! Thank you very very much for your help, man! It’s probably very simple for u but it’s very meaningful for me!

Now I am embarassed to ask this but I didn’t understand this part ot the tutorial:

You can just double click on the file to open the starter.

Which file? I thought it should be but I tried that and nothing happened

And I am using windows but I realized that the page don’t show what to do in the last step for Linux and Mac users. At least on my computer it only shows a empty label when I click on Linux or mac button / link.

1 Like

Yeah, don’t worry about that :sweat_smile:

Just execute it with python

1 Like

Well I typed that on ms-dos but I am not sure if I did it correctly.

What now?

It’s done

Just go to and check for the checks

1 Like

Is Starter running?
Yes, it is running…

Is your phone connected?
No, it is not connected.

The phone is connected and the USB debugging is enabled

Make sure that is connected as “File Transfer” and NOT “Charging”

1 Like

Yeah, it’s conected as multimedia device (MTP).
I even tried to copy a file from my phone to pc and it worked well.
Any tips?