Why Admob Ads Are Not Showing In Kodular?

We all know kodular is the most advanced app development platform for making apps through blocks. It always upgrades its SDK to the latest version, where other sites like appybulider, thankble are not updated till now.
But what about the ads???
Every time by time we faced issue with Admob, why??
Every genuine developer who makes his app by hard work they also faced the Admob ads issue.
My problem in some simple words is -
I created a content app with kodular, my all Admob banner and interstitial ads are working fine in test mode, But not working with my AdMob ad units id, no ads are coming up. There is no problem with my Admob account.
I test my app with appybulider and thankble and there also have the same ads issue, but one thing if I sign my apk file which I created from appybulider and thankble with APK EDITOR SIGN than ads are coming perfectly. But this is not happening with kodular created apks.
So, if I sign kodular created apk with APK EDITOR then I problem remains same but worked for appybulider and thankble.
I have tried these things, and I want to tell you guys & also to Kodular to fix this Admob ad problem issue.
If anybody has any suggestion then please reply down below.


I think this is not fault of kodular… Because all of my app are showing ads perfectly

when you created your apps?? are old or you created them recently?

Yes some of them are old and some are new… Working properly

are they all published in play store?

I uploaded only one app on play store

In your apps ads are coming in all day or you faced any issue like less ads in night?

Sometimes ads don’t load :thinking::thinking::thinking:

oh :hushed: thanks for replying
So what your opinion about how to show my ads?

How are you showing them currently?

Yes I show them today, with a apk file signed with apk editor key.

You should search for that in the community and also show how you load ads in your blocks. I don’t know if that’s the case, but don’t load ads when screen starts.

Is this is a some kind of Quiz Show

What do you mean? :thinking:

It looks like a quiz you are asking questions and he is answering and then you are asking opinions.

1 Like

My old apps are working perfectly but recent ones are not

This is same issue I’m facing right now and it started since the new update to Draco 1.3B
Old apps I create before the update are still working. Ads are working during live test but not working once you export it out

I also did some test to see where is the exact problem may be = Admob ads not working on Kodular

Admob ads showing during testing but when i create apk file and install on phone ads are not showing, already unchecked test mode. Someone tell mee???

1 Like

The companion can’t show live preview components such as lottie or ads