Airtable Index changed everytime

I am unable to set airtable row data to different lables. Already tried methods that are described on community. Everytime index changed and data sets to different labels.

Mean? Can you tell us more?

Then you may added +1 to the index and also might have placed the index in wrong place instead of exact one.

I use airtables on all my apps. I update cells and rows without any trouble.

You should show some blocks of what you have done, that way we can see what’s wrong with the blocks.

Remember that the index of values in Global list is same index as in airtables. So if you delete anything from a global list, you also have to delete it from airtables and vice versa. Or else the next changes will be on wrong index.

You could also make a column named ID. Then always make a unique ID for every row created.
That way when you want to make changes you just lookup the index of an ID, then you have the correct index.

Blocks for the project.
Everytime when i refresh the screen, data sets to different labels.

Every thing is looking good can you also provide pic of your database structure?

Please solve the issue.

So as i find out you have some empty cells try filling those cells and try again.

The row which i calling is not empty.

Ok so can you share you aia so i can look at issue?

Is it safe to share project aia?

Share in private

Can you please solve it here?
Issue is label 1 gets cell 2 sometime cell 4

It’s quite hard to find solution without looking at aia.

When you open app first time then it’s show right data?

Everything goes fine at every step.
Problem is in getting index no.

Can you tell what number it indexing?

index of thing - ezvtu…
list - ID

data is geting but not in proper order

Not this what it’s index position like 1,2 or more click on do it on index block

Have you tried using “Do it” on global index when connected to companion after you get ID column?