Airtable Spreadsheet How to show all entry of a column one by one after specific time?

hello friends i want to show all entries of a specific column ( Airtable Spreadsheet ) one by one after specific time (minute / seconds) and i also want to loop it, One it reaches last entry it should start from first entry but i have no idea how do i implement this.

this below show all entries at once:
blocks(1)

When Screen Initialise Call the whole Column Data.
And store it in a List.

Use a Clock set it’s interval to the Desired delay after which you want to show more entries.
And with Clock use this Block with Variables.
blocks (6)

3 Likes

i tried this now how i use clock to show entry (value) one by one

From Designer Screen Clock interval is set to 0.
So, as soon as Airtable gets value First 10 elements are showed.

Then using Blocks interval is set to 10 Seconds.

So, After Every 10 Seconds.
10 more Elements are Displayed.

You can Change them Accordingly.

1 Like

well thanks but i still need your help i copy your code blocks:

now this is how it works:

but how i want it to work:

i want to show one value or entry at time then after 5 seconds it should show 2nd value then 3rd then n…number then10th and then restart from 1st value to 10th value, i want to show every value one by one

just remove the “join” Block.

2 Likes

like this:
blocks(1)

now it show only 10tn value

Yes, Correct

1 Like

but now it only show 10th value, it is not showing values one by one.
should i attach aia

in for each number loop
set “to” to 1

1 Like

i am very sorry but problem is still same, i set “to” to 1 now it show 1st value only
please look if i am doing any thing wrong:

airtable_copy.aia (3.0 KB)

in design view i also tried clock Time always fire on / off but still issue

1 Like

in “to” set global number + 1

1 Like

this worked it start showing value from 2nd to 10th but after showing 10th value i am getting error:

use a if then statement after timer enabled to false.

if global number > 10
then set global number to 1

1 Like

set “to” to global number

1 Like

i did this but getting same error please look if i am doing wrong
blocks(1)

1 Like

I don’t see any use of the for loop @alldownloadworld .You can easily do like that.
blocks - 2020-08-25T204028.081
And from the designer set timer enabled to true.And timer interval to 2000 ( can be set from blocks).

1 Like

well thank you @Mohamed_Tamer and also very thank you @ADDYLIN you really helped me a lot
this is finally now working:

2 Likes

Yes True,
i was making the Blocks at 1pm night partially sleeping.
i don’t noticed that he now is just asking for 1 value at a time.
i kept editing the 10 values block.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.