[🎂 bug] Get Plain Start Text = *nothing* bug

I checked out Kodular Fenix (v1.5.0) Bug Tracker before creating a new topic

Describe your issue

the get plain start text block returns *nothing* and the app crashes (while using the apk file)

Steps to reproduce the issue

use a Screen.Initialize event and display the get plain start text in a Label

Expected Behaviour

the get plain start text block returns an empty string

Actual Behaviour

the get plain start text block returns *nothing*

Show your Blocks

Unbenannt

example project: GetPlainStartTextBug.aia (1.5 KB)

Android version

tested in companion Version 1.5.2 and apk file on Samsung Galaxy A51 running Android 11

Taifun

6 Likes

@Diego any news about this bug?
I reported it already 3 months ago…
Taifun

3 Likes

Here is the 5 months reminder…

( I know, that reminding will not help very much… unfortunately… but how can you wake up a sleeping Kodular team?) :sleeping:

Taifun

7 Likes

i think they even not checking community

2 Likes

It looks like as we soon will get a new Kodular release, see also this post by @pavi2410

Let me therefore politely and respectfully ask the @Kodular team to fix also this bug, which already has been reported in September 2021…

Taifun

2 Likes

Still not fixed :confused:
Any suggestion for a workaround? I’m using your extension Alarm Manager, but on app initialize(without an alarm been set off) it gives the error as you described.

Like a bunch of other bugs I’ve pointed out often enough.

It’s kinda frustrating.
I know that most bugs has different fix-time, some may take many days/weeks or more to fix, but also many could be fixed within hours. But when a bug haven’t been fixed for almost a year, then I can’t say the developers/leaders take it seriosly. Atleast they could reply so we know they are aware of it.

I have deep respect for them for the time they use on Kodular, some have fulltime school, work, family also. BUT with so many thousands of users using (even developing extensions for) Kodular it’s kinda odd that some of these bugs that are very neccessary to actually work doesn’t get fixed asap.

This feature with getting Plain Start Text is something you must have to be able to fetch data outside app into app.

I really hope they will fix it soon.

2 Likes

Please test again using the latest Kodular Fenix 1.5.5 and let us know, if they fixed that bug now…

Taifun

No (as expected), but that’s just the smallest issue we’re currently having.

2 Likes

I now introduced a new bug category… the birthday :birthday: bug… this is a bug, which has been reported more than 1 year ago and still not has been fixed…

Remember… because of this bug it is not possible to pass any information from a notifier (or a third party app) to your own app… this actually is an important feature and does not work in Kodular since more than 1 year now…

Happy birthday…

Taifun

3 Likes

It won’t be a year for another 15 days…

you are correct, however this bug has been introduced with Kodular 1.5.0, which has been released on July 15, 2021

I reporrted the bug in Sept 30, 2021… let`s celebrate in 2 weeks then… :clinking_glasses:

Taifun

1 Like

4 posts were split to a new topic: Some Feedback for @Kodular