Error 1103: Unable to post or put the text

I’ve searched, can’t find a solution. Tried clearing cache, tried Chrome and Firefox. Same problem. Running “python3” on my server, seems happy enough. But no joy on connecting via companion or USB cable. Samsung S6 USB debugging is ON.

Screenshot from 2020-09-05 10-08-23

What am I doing wrong?

@TwoCanes_LLC Welcome to Kodular community.
Make sure companion updated to version 1.4D.1 And check your network connectivity.

1 Like

Thank-you very much for your welcoming.

Companion was uninstalled and reinstalled to v 1.4D.1. S6 phone has wireless connectivity, verified by Chrome. I had USB working at one time, now I get errors:
Screenshot from 2020-09-05 11-57-32
Screenshot from 2020-09-05 11-57-47

Phone shows blank white screen with Kodular header (purple) with 3 dots that verify it is a Kodular application.

Have you followed this steps @TwoCanes_LLC :

1 Like

Yes. Yes, I did read and follow that doc. :slightly_smiling_face:

% /usr/bin/adb version (09-05 12:27:00)
Android Debug Bridge version 1.0.39
Version 1:8.1.0+r23-5~18.04
Installed as /usr/lib/android-sdk/platform-tools/adb

% python3 -V (09-05 12:26:47)
Python 3.6.9

% pip install -r requirements.txt (09-05 12:20:34)
Collecting bottle==0.12.17
Downloading bottle-0.12.17-py3-none-any.whl (89 kB)
|████████████████████████████████| 89 kB 171 kB/s
Installing collected packages: bottle
Attempting uninstall: bottle
Found existing installation: bottle 0.12.13
Uninstalling bottle-0.12.13:
Successfully uninstalled bottle-0.12.13
Successfully installed bottle-0.12.17

% adb devices (09-05 12:24:33)
List of devices attached

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    02157df29da60415 device

So adb finds my phone. Running seems to work:

% python3 (09-05 12:24:40)
Kodular Starter version: 1
OS: Linux
Architecture: 64bit
Machine: x86_64
ADB path: /usr/bin/adb

Bottle v0.12.17 server starting up (using WSGIRefServer())…
Listening on
Hit Ctrl-C to quit.

So I start Companion on the phone.

In Creator, I drop down the Test menu and hit “Connect via USB”. I get the Connecting dialog on the Creator. Then, almost immediately, I get the Internal Error dialog. I wait two minutes, nothing happens. If I hit Cancel (Internal) Error 15 times or so, nothing happens. If I hit “Report Error”, an Open Bug page pops up. I close that page, go back and both dialogs are still displayed. So now, I hit Cancel Error about 14 times and the dialog disappears, the Connecting dialog disappears and my project will finally display on the phone.

However, that is using USB, and it seems like an awful lot of machinations to even get the USB to work. Do not understand why there is any error displayed.

The Companion still does not work. I have used the QR symbol and code many times, never does it connect.

1 Like