Get Data from Airtable

This property:
Should be equal to Table.It should be the same name of the section as you say :wink:

did but still not working, will this show on companion screen or i will have to download the app. sorry to trouble you so much but actually i am completely new to this

both the name of your table and the name of your columns when you enter them have to be exactly as you wrote them in Airtable

For that reason it does not show you its content, neither do you store anything in the

Check your base id and api key.

See this guide to know how to find them:

i checked it its perfect

I don’t think so, i’ve made a test with your data (channged yumn to Table ) but it doesn’t work.I can confirm that the problem isn’t from your’s a problem from your airtable info.Check this guide to know how to get them properly:

i know how to send data to airtable, but i am finding it difficult to call data, my apikey and base id is correct

I modified your data because you had an evaluation error in your blocks but it still doesn’t work

You must have typed in the wrong Api or ID

This was your mistake:

you were making a switch with the counter variable and then you do it with the variables that stored the data

how can i correct this, if this is not working is it possible or can you guide me i am able to bring data from airtable to list but sometimes it comes and sometimes not its in screen 2

As i’m said an repeazting.The problem is in your api key and base id check them please :wink: I’m sure it works.:

this is my api key & base id i am using and this is correct

I will make a database or table in airtable and you will see that it works
Of course, as long as the Api and ID + the table name and its fields are spelled correctly

I’ll pass you the AIA

My tests says they aren’t correct:

i don’t think you will get the base id from here,as i see the curl place is empty.
here is the place it will be there in the authentication section.

It should work for you, if as you say
The Api and ID are correct!

I Will be highly obliged if you do this :grinning: :pray:t2: :pray:t2: :pray:t2: :pray:t2:, but i took base id from here only to the form i am using to fill data

The one entered in your project is not correct then
Because with the screen you show other keys

Your blocks are correct.No need to create them again.Just see this:

its the same, please check for ID of base in screenshot i shared

Have you even read the guide that @Mohamed_Tamer said the you can troubleshoot your problem yourself and never share your personal details in community that can cause you any kind damage of your data

1 Like