Google map doesn't load in first time

Hello koders, I am facing a bug. google map doesn’t load on the first attempt. no road, nothing. when I quit app & again open app then it load. First time it loads on 3rd attept by quite & reopen app. & second time when I clear data of app & try again then the map loads on secend attempt. Didn’t load on first attempt. why ? & my project doesn’t load in companion I don’t know why after using static variable extension

I added a spinning progress to check map ready or not. In first attempt map doesn’t get ready

& today first attempt in satellite view

& normal view

Search the community

Man i already use google api.

Man i think you didn’t read properly I said and my app doesn’t load in map. that mean i said about apk.

Maybe map is not ready when you first load it. Try to show map when ready using a progress bar

1 Like

I already did that & map doesn’t load in first attempt
blocks (75)

. I added my apk also

Please don’t usernames to just get attention.

Can you show where you entered your api key in the settings?

I will get any solution or not by kodular?

1 Like

is not there any solution?

  1. Need to use Google map api key

  2. Must create map style from the billing management. Then only map will work in the app. If not you will see blank screen only

I use google map api key, & it doesn’t load in first attempt, if I open app in second time or later it works.

i did not understand this point

Follow this,

1 Like

i did all that things but same result

replace the api I think something is wrong because my map is showing up in the lab and when I install the app

i change the api but same result

can you show us your google map management and map style page screenshot?

1 Like