How to solve tinydb error

Hallo everyone, I tried to retrieve data from tiny db after I did store value from airtable to tinydb, data managed to enter tinydb but when the data in this error retrieved appears, the system tries to retrieve data number 3 at which time there is no data number 3 on the airtable, can you help me to this?
Screenshot 2022-03-25 101941

Show us call tinydb get entries by using Do it

The problem is, you are counting the value tinydb tag value but you are using dictionary mode to take the item. It won’t work. I hope … to make us clear(for me) if you show the structure. of your tinydb datas it will be good to suggest

Replace lenght of list get database lenght of get keys get database


With lenght of get keys get database


because I found this way in a kodular diforum with a discussion similar to what I was looking for, therefore I tried it sorry if I gave the wrong information

I still get the same error

Click on call tinyDB get value, use Do it and post a screenshot or post a test aia that shows the problem

Yours is little bit different. We need to see your tinydb structure

Do It Result: {“link”:[“ABSEN.xlsx - Google Sheets”]}

Do It Result: {“link”:[“ABSEN.xlsx - Google Sheets”]}

Then try to replace lenght list with

blocks - 2022-03-25T090341.771

i save data to tinydb that way, I see such a way in this forum

Try as I said


replace with


This is what I got

I hope you are checking in companion.

So just clear your tinydb, then restart the work , i mean save intinydbbfrom the beginning and try

before I reply to the message from dora I’ve done it clear all in tinydb but I still get the same thing, try aia.
test.aia (9.3 KB)


test_9a.aia (9.6 KB)

You replaced all blocks with lenght instead of select list item list

1 Like

sorry I changed it wrong, but you’ve helped me solve this problem thank you for helping

1 Like

If problem solved please mark solution :white_check_mark: in order to help others