How to use In-App Update Component

How to use In-App Update Component

Note: For In-App Update Component to work you should have uploaded your app to Google Play Store.

A. Check for an update when the screen is initialized:

1. Flexible Update

Start%20Flexible%20Update
It will start a flexible update; what that means is your user will be able to use your app while the update will get downloaded in the background.
The update will be either installed when the user restarts the app or by this method given below:
Install%20Flexible%20Update

2. Immediate Update

Start%20Immidiate%20Update
This will start an immediate update, and the app can not be used in the duration of the update.
After it gets downloaded it will automatically get installed.

B. Update Failed or Cancelled

Update%20Cancelled%20or%20failed
You can use this block to notify the user that the update either cannot be installed or the user has cancelled it in which case you can ask the user to retry.

C. Update Installed

Update%20Installed
This event will rise when the update has been successfully installed in this you can put a notifier or close application or move to screen block

That’s It.
This was my first guide please feel free to correct any errors.
/Ravi Garg

13 Likes


Is this right?

2 Likes

Correct the notices from ‘Upgrade Successful/Failed’ to ‘Update Successful/Failed’
Upgrade is used when you are changing hardware parts and for software you use update

1 Like

Ok,i will
I hope this works

1 Like

Yes It is correct just change upgrade to update

1 Like

In my case it is not working .

1 Like

Please check your blocks and ensure the minimum API requirements

1 Like

I have added minimum api requirement to 4 , but i have the upper level

1 Like

Minimum Api should be 5.0

1 Like

i have done usig 9 version of android but it doesnot worked

1 Like

The version of your phone doesn’t matter.
What you need to change is minimum API in screen 1 settings to API 21 (Android 5.0)

1 Like

Is this needed for the first application that published on playstore

1 Like

That has no relation with first, second or third application.
If you want to use kodular in app update component you need to:

1 Like

I will try it

2 Likes

Did work for me!

2 Likes

Hello!

Where do I find the In-App component?
I looked everywhere in Kodular, can’t find it.

/Boban